Sunday, March 6, 2016

Exchange 2010 SP3 Rollup 10 fail with PS version 4.0

Recently We have upgraded our DAG servers with WMF 4.0 as our Storage solution required it. After upgrade few of the scripts broke for which we have implemented some workarounds but this Post is not about those scripts , It is about the issue we faced during installation of the Rollup 10.

We were able to upgrade CAS servers successfully but on DAG servers installation failed with error:

“Setup Wizard for Update Rollup 10 for Exchange Server2010 (KB3049853) ended prematurely”

cap

Than we enabled logging by following below steps:

  • Enable installation logging. It can be done in 2 ways


http://blogs.msdn.com/b/astebner/archive/2005/03/29/403575.aspx

Use command : exe /p <MSP path> /log "C:\Users\<username>\Desktop\Test.log"

  • To find the error, look for “return value 3” in the logs


cap

Now you can see that servicecontrol.ps1 script is failing.

cap

On further analysis it has been found that error relates to script: ManageScheduledTask.ps1 :)

You-were-picked-and-have-got-the-answer-right-GIF

To fix this error you have to modify the script:

Open the script “ManageScheduledTask.ps1” in Powershell ISE

cap

Go to line 462, and replace “return $success” with “Write-Output $success” and save it

cap

Now when you will try again Rollup will install successfully. This error can come with PS 3.0 as well as 4.o. Our CAS server were on PS2.0 so error was not encountered & DAGs reported the error because of PS version 4.0.

Thanks to my Teammate Alex, who have done troubleshooting ,searched the Internet & found the Fix.

Note: Do consult with Microsoft before following this procedure.

Update: Checked with MS, they will not officially support this but what they support is below:

Uninstall WMF 4.0

Install Rollup 10

Install WMF 4.0

 

Regards

Sukhija Vikas

http://msexchange.me

 

6 comments:

  1. You realize this is a totally unsupported procedure and thus you have created an unsupported (customer?) configuration?

    ReplyDelete
  2. Ps 4.0 is supported with exchange 2010 but it breaks few scripts..we already have a ticket opened with Microsoft..

    https://technet.microsoft.com/en-us/library/ff728623(v=exchg.150).aspx

    I have added a Note after reading your comment so that people consult with MS before following this ...

    ReplyDelete
  3. Hi Vikas, your note regarding consulting MS is good, but personally i would never recommend following this procedure, I'm sorry.

    ReplyDelete
  4. No other option if wmf 4.0 is there on exchange 2010 installation..I am still checking with MS if there is any other option available & will post if its there..

    ReplyDelete
  5. Update: Checked with MS, they will not officially support this but what they support is

    Uninstall WMF 4.0

    Install Rollup 10

    Install WMF 4.0

    ReplyDelete
  6. I dont have WMF 4.0. still at power shell 2
    Still can't install the

    ReplyDelete