Saturday, April 12, 2014

SharePoint CU upgrade error System cannot find path specified

Hi Readers,

We were upgrading CU on SharePoint server 2010 and when we ran configuration wizard it failed. After we checked the upgrade log below was the error:

System cannot find path specified

Researching it a bit we found that its related to some missing zone on one of the webapps.

You can use below script to find out what zone is not present in Central Administration:

$webapp = get-spwebapplication “http://failedurl“
foreach($setting in $webapp.iissettings.values)
{
$setting.path
}
foreach($zone in $webapp.iissettings.keys)
{
$z = $zone
echo $zone

Use this one script to remove the zone that is not showing up in Central Admin

$webapp = get-spwebapplication “http://failedurl“
foreach($setting in $webapp.iissettings.values)
{
$setting.path
}
foreach($zone in $webapp.iissettings.keys)
{
$z = $zone
}
$webapp.IisSettings.Remove(“zone that is not present in central admin but reported by above script”)
$webapp.update()
}

After doing this, run the Configuration Wizard again.

reference:- http://sharepointfreshman.wordpress.com/2012/03/02/3-exception-the-system-cannot-find-the-path-specified/

Regards

Sukhija Vikas

http://msexchange.me

1 comment:

  1. Thanks a lot !! This saved me - I was battling with a patch being STUCK - and it was a prior company had tried to do a 443/SSL extranet - and deleted the IIS WEBSITE - but it was still registered within SharePoint - thanks, this helped me a lot ! :-)

    ReplyDelete